TaleBlazer TaleBlazer

TaleBlazer Mobile

Android

TaleBlazer Mobile for Android is available via the Google Play Store.

Google Play Services and Android version 4.0 or higher are required. Support for older versions of Android has been deprecated.

GPS positioning is required for outdoor gameplay to function correctly.

Google Play

Or download the shipping apk from here:
TaleBlazer Mobile 3.2.5 - September 6, 2018

If you cannot install TaleBlazer to your Android device, please contact us at

support@taleblazer.org

iOS

TaleBlazer Mobile for iPhone and iPad is now available via the App Store.

GPS positioning and iOS version 6.0 or higher are required.

App Store

Beta Program Android

If you would like to be included on our testing team, please contact us at

support@taleblazer.org

Beta Program iOS

If you would like to be included on our testing team, please contact us at

support@taleblazer.org